OSDN Git Service

CLI: SubRip Subtitle import
[handbrake-jp/handbrake-jp-git.git] / gtk / ghb.spec
1 %define name HandBrake
2 %define release 1
3
4 Name:           %{name}
5 Version:        %{version}
6 Release:        %{release}%{?dist}
7 Summary:        A program to transcode DVDs and other sources to MPEG-4
8
9 Group:          Applications/Multimedia
10 License:        GPL
11 URL:            http://handbrake.fr/
12 Vendor:         The HandBrake Project
13 Source0:        %{name}-%{version}.tar.bz2
14 Prefix:         %{_prefix}
15 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
16 Requires:       glib2 >= 2.16, gtk2 >= 2.12, hal-libs, webkitgtk, gstreamer
17 Requires:       gstreamer-plugins-base
18
19 %description
20 HandBrake is an open-source, GPL-licensed, multiplatform, multithreaded 
21 transcoder, available for MacOS X, Linux and Windows.
22
23 %package gui
24 Summary:        A program to transcode DVDs and other sources to MPEG-4
25 Group:          Applications/Multimedia
26
27 %package cli
28 Summary:        A program to transcode DVDs and other sources to MPEG-4
29 Group:          Applications/Multimedia
30
31 %description gui
32 HandBrake is an open-source, GPL-licensed, multiplatform, multithreaded 
33 transcoder, available for MacOS X, Linux and Windows.
34
35 %description cli
36 HandBrake is an open-source, GPL-licensed, multiplatform, multithreaded 
37 transcoder, available for MacOS X, Linux and Windows.
38
39 %prep
40 %setup -n %{name}-%{version} -D -T
41 #%setup -q
42 #cd %{_builddir}/%{name}-%{version}
43
44
45 %build
46 #./configure --prefix=%{_prefix}
47 #make -C build
48
49
50 %install
51 #rm -rf $RPM_BUILD_ROOT
52 #make -C build PREFIX=$RPM_BUILD_ROOT PREFIX/=$RPM_BUILD_ROOT/ install
53
54 ## blow away stuff we don't want
55 /bin/rm $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %post gui
61 touch --no-create %{_datadir}/icons/hicolor
62 if [ -x /usr/bin/gtk-update-icon-cache ]; then
63   gtk-update-icon-cache -q %{_datadir}/icons/hicolor
64 fi
65
66 %postun gui
67 touch --no-create %{_datadir}/icons/hicolor
68 if [ -x /usr/bin/gtk-update-icon-cache ]; then
69   gtk-update-icon-cache -q %{_datadir}/icons/hicolor
70 fi
71
72 %files gui
73 %defattr(-,root,root,-)
74 %doc NEWS AUTHORS CREDITS THANKS COPYING
75 %{_datadir}/icons
76 %{_datadir}/applications
77 %{_bindir}/ghb
78
79 %files cli
80 %defattr(-,root,root,-)
81 %doc NEWS AUTHORS CREDITS THANKS COPYING
82 %{_bindir}/HandBrakeCLI
83
84 %changelog
85 * Sat May 31 2008 John Stebbins <jstebbins@jetheaddev.com> 
86 - Initial release
87
88